Image Display File Paths


#1

Hi Jim, my heartfelt condolences because of your deceased MacBook Pro, especially. as the same happened to mine at the beginning of this year. A real pain in the backside to restore everything to a new computer, strings, serials, etc.
Right now I am struggling to make a picture database work and although I follow the instructions given in “240 Image Display” I just can’t make it work. Maybe you can help without your laptop as well, if not, I’ll wait patiently until you get it.
I have a photo hardware database which I converted from Pro 6. There it worked for a long time without problems. In Pano X I made a new form “Big Pix” where the images of the hardware are supposed to appear.
I created an “Image Display” object in this form and in its Formula window I put:
"/Users/isza/Documents/primary Docs ƒ/Photo/Photohardware ƒ/Photohardware-jpgs ƒ/"+BIG PIX
which is the full pathname + the field BIG PIX which contains the individual image titles in each record,
e.g. AsaPentax LX 53497.jpg or AgfIsolette I35944.jpg
The folder Photohardware-jpgs ƒ is in the same folder Photohardware ƒ as the Pano X database, so this full pathname would not even be necessary, but it won’t work neither with the full pathname nor with the shortened one.
The image titles are one-of-a-kind, there is no repetition there.
What am I doing wrong?


My Macbook Pro died again :(
#2

The problem is the space in the name of the BIG PIX field. When you have a space, or some other character that is not alpha-numeric in the name, you should put chevrons around it. «BIG PIX»


#3

Thanks for the suggestion. I corrected all instances of BIG PIX and it’s now BIGPIX. I got a bit further: the Image Display Object I created to display the image now shows in text form the full path and the image title (it practically describes the image) but doesn’t show it. Why?


#4

You must have enabled the Display Path (Debug) option.

but doesn’t show it (the image)

This means that the path or name you’ve supplied is wrong. Everything has to be EXACTLY correct, even a single incorrect character and it won’t work.


#5

One way to make sure you get the folder path correct is to drag the folder into the box for the formula.

This gives you the path, without the slash that separates it from the file name. Next, you would add the slash, put quotes around the path, and put + BIGPIX after it.

If the image still doesn’t show, it means that BIGPIX has the file name wrong.


#6

Thanks for helping! Playing around with variations I finally discovered it just before reading these posts. I put the image folder’s path between quotes and with a + added the field BIGPIX which contains the image titles. But I didn’t put the slash after the pathname and before the closing quote. Once I put that in the images started to flow into the database. So that’s settled now, thanks to all of your help.