Can't Close File


#1

I’ve had this happen periodically and have not tried to replicate it. It may be caused by run buggy procedures, but I don’t know. It has happened in several files on two different machines.
I will get a file that I can’t close out of manually. The red X will click. The File menu will light up if I try keyboard close. I can close every window except the last one. If then open a new window, move back to the previous window, I can close that and the new one won’t close.
If I run a closewindow statement in a procedure, the last window WILL close.
As far as I can tell, I can do everything else in that file, change forms, edit, toggle between Graphic and Data modes, minimize/maximize. Just can’t close the window.


#2

I’ve experienced it too, once, about a month ago when I noted but didn’t post:

Pan X is fully responsive to any action I take EXCEPT, it won’t quit or close the last window. I can open other windows, then close what had been the last window. But when I get down to the final window, no dice. It doesn’t matter what kind of window either. It can be a procedure, a form, a form in Graphics Mode, a datasheet…

Close Database doesn’t work if it’s the last database.

Finally Force Quit even though it worked normally in every other way.


#3

Check to see if the database is still listed under Memory Usage… I’ve sometimes had databases that no longer were listed there, yet still had a window showing. Which couldn’t be closed other than by Quitting or Force Quitting Panorama X. I haven’t yet figured out how to reproduce it so hadn’t reported it. Restarting Panorama X solves the problem and I haven’t spotted any pattern in its infrequent recurrence other than that the offending window’s database is never listed under Memory Usage…


#4

Happening to me, too.

Click “Save” and that dialog box goes away, but won’t close nicely.

Screen%20%2045

Screen%20%2047