Volume Path Variations

It seems that there are inconsistencies in how Panorama handles the paths of volumes. If I drag a file from a mounted volume, the path that Panorama gives me is something like “/Volumes/jamescook/Files”.

But if I want to list or otherwise access the files there that path doesn’t do it. For one thing, with three computers and each one in this case with me as a user, that much can exist on every mounted volume. To list files, I need to add more, in essence: “/Volumes/Macintosh HD/Users/jamescook/Files”

How can I capture the complete path when a user clicks a button or drags a file to indicate the location of a file or folder?

That seems wrong. /Volumes/ should be followed by a drive name.

I’m not sure how that will work if each of the three computers has the same disk name.

That said, this is really a UNIX question – I’m not an expert in this area. Panorama just reflects what UNIX is doing.

The disks do need different names. Once you get past that, most have structures we don’t have a lot to say about, such as Users, Library, …

The only part I’d hope Panorama can help me with in that is in getting the full name on that drag at the outset.

Where are you dragging it from? Something in the Finder? That’s where the path is coming from. Panorama is just the receiver of the drag, it’s not originating the information. Panorama can only give you what the sending application supplies.

1 Like

It has been presented here many times that an easy and reliable way to get a path is to drag a file onto a Text Editor. The path is then entered into the cell.

I’m really reaching here, because I only have one computer to play with, but when I tried mounting two disk images with identical names, they appeared identical in the Finder, but dragging files from them into a Panorama window resulted in something like “Drive Name” and “Drive Name 1”. “Drive Name 1” was the second one to be mounted.

Two computers on the same network could easily have different names for the same shared volume, if they had the same name but were mounted in a different order, or if the volume in question was the boot volume for one of them, but not the other.

I’ve never had a problem doing that, but I can’t remember if I’ve ever done that from a shared volume. However, the way this works is when you start the drag, the Finder figures out the path and stores it in a virtual container. Then when you drop on another application, for example Panorama, the receiving information can access the contents of the virtual container. But the receiving application has nothing to do with what the content being dragged is, that content is always generated by the application where the drag starts.

I had to do this awhile back to change the names of files in a folder on the server and/or delete them. I did this to access folders and files on a server:

local the folder, the files
thefolder=folder(“servername:Documents:Post Export:”)

I then used a counter to do things like:

movefile folderpath(thefolder)+array(thefiles,counter,¶),
FileTrash fileFolder,array(fileList,counter,¶)

surely you mean thefolder, the files

thefiles (OF COURSE)

Ok, I was wrong. When mounted as a network drive, you don’t see the volume name on the other computer, you see the name of the shared folder you set up on the computer. I think you must have set up a shared folder of jamescook. When I tried it, I dragged the folder into Panorama and I got a path that worked to access the content of the folder.

On another thread, there was a mention of using diskutil to mount a network drive. I don’t see how that could work. In my tests, network drives do not show up in the diskutil list.

It looks like perhaps the mount shell command is the way to do this. This web page seems helpful, I almost got it working using his method.

But the computer containing the folder I want to mount keeps rejecting my password, I get this error.

 mount_smbfs: server rejected the connection: Authentication error

I’m stuck for now.

You are correct cmcp, and don’t call me surely :slight_smile:.

I was in a hurry when I wrote that post. Jim Rea is correct. I didn’t make it clear but Post Export is a shared folder. I was getting similar results to JC in trying to access the volume. I couldn’t find a way to do that which is why I made a shared folder so I knew where the files were.