Unknown object class

I have a large and very complex database which is exhibiting strange behaviour so I thought I’d check out the effect of exporting and re-importing a database blueprint, a tactic that has helped in the past.

The export appeared to work (hard to tell really) but the import threw up this message:


With several hundred objects across multiple forms, what’s the best approach to identifying the culprit?

I made a copy of the file, removed forms one by one and repeated the blueprint export/import process for each iteration. The same error came up every time. With all of the original forms deleted, I created a new one with just a rectangle on it. Same result. Where else do I look?

This error message is supposed to display the class that was requested. For example, if the code contained

newformobject "Spiral",...

Then the error message would be:

NewFormObject error: unknown object class (Spiral)

Since in your case only () is being displayed, I think the blueprint code must contain

newformobject "",...

Before you ask, a blueprint should never contain code like this. Since the code is computer generated it should always be perfect. But perhaps whatever is causing the strange behavior in the first place also caused the blueprint to be generated incorrectly.

I don’t have any newformobject statements but I think it’s called by several other statements so that could be it. In fact, I fixed it by re-installing Panorama X so who knows?

I’m also getting frequent occurrences of:


which used to have the rider, “… because it doesn’t exist” which always amused me even through the irritation.

I was referring to the code inside the blueprint, which will have a newformobject statement for every object in the form.