Text entry bug with Command-up-arrow

  1. I typed some text in the Notes field of my life. 2. I saved the file. 3. Typed more text in the Notes field. 4. Typed Command-up-arrow. Result: a duplicate record was created, including the unsaved portion of the text, but the currently active record lost the unsaved text. Then the app crashed when I used the up and down arrows to move from record to record. I believe that the Notes text of all three records. (This bug occurs only if more than one record in selected, so first I created a dummy record called Text 1). I can upload a copy of this file, stripped of all except these three experimental records.

Sure, you can email me the file and I’ll check it out.

Thanks, Jim. Here it is.


Jim, there’s another problem in this file: searching in one field doesn’t work with more than one character.

I think you tried to email the file directly to the forum (perhaps you are accessing the forum thru email, rather than thru the web). You can’t email attachments to the forum. You’ll have to email the file directly to me. I’m not going to put my email address on the forum, but I’m sure you know what it is.

You’ll need to provide some additional detail for this rather extraordinary claim. Perhaps there is something super special about your database, but if searching with more than one character didn’t work I’m sure I’d be getting complaints day and night for the past two years. So you need to help in letting me know what is super special about your database and how exactly to see this problem.

No Jim, I don’t have your email address. May I have it now?

Thanks to a tip from Dave Thompson, I was able to locate and download your database (Stuart). And I was able to duplicate the problem with Cmd-Up/Cmd-Down. I’m guessing what you really wanted these to do was move the insertion point to the top or bottom of the note you were editing?

I still have no idea what you mean by that. I tried searching for items in your database that were more than one character and it worked fine. Please let me know exactly what to do to duplicate whatever issue you are seeing.

Yes, Jim, what I was trying to do. I use this keyboard command constantly without thinking, so I do think you should disable it as Dave Thompson suggests.