Table Summary Issue

I’ve been playing with PanX using some existing Filemaker files. One simply tracks daily service miles for vehicles. I’m using a simplified single vehicle dataset to work on summaries (and ultimately reports). As I build the summary the year structure in the preview looks correct (ie, 2011, 2012, 2013…2018). But when I run the summary I get pic 3. The miles total correctly, but the years do not display. Instead, single dates within the year are used. I can’t figure out what I’m doing wrong. The year value is a calculated value formatted as an integer.

Instead of using the Date field to group up by year, use the Year field to simply group up.

Starting with what you have now, you can Morph and use Start with Formula to fill the Year field with


Thanks. I was expecting to use the Year field, but it is not presented as an option when setting the summary parameters. I don’t know if that’s because it is a calculated value (ie, Yearvalue(Date), or some other reason.

Just an update. The same data set worked as expected when the originating CSV included Year values. The import process made the field a text format, and the field was visible. I changed the field to integer as a test and got my previous result. Does anyone know when integers/text/other fields are discoverable and when they are not?

It was because it was a number field. You can change that in Preferences.

09 AM

Even if that box isn’t checked, you can group on any field, by selecting it, and then choosing Group Up or Group Down from the menu.