Rich Text Anomaly

I have a TDO set to Rich Text. It is referencing a field named “Tooling” image shows the data, formula and results.

Notice the extra “<” and “>” at the start and end of the the yellow highlighted TDO . That extra “<” and “>” are not in the data. Is this a bug?

You have overlapping tags throughout which is likely to create some sort of failures. Possibly that’s the issue.

I can’t copy from your screen shot, but you can’t have the likes of:
It would need to be:

Here is the result when all rich text tags are removed.

I set up a sample db with one field named Tooling with this in the cell:

<DieNumber>Digital</DieNumber>¬<ToolType></ToolType>¬<Shape>Square Corner Rectangle</Shape>¬<CornerRadius>0</CornerRadius>¬SizeAcross>11</SizeAcross><SizeAround>8</SizeAround>¬<SpaceAcross>0.25</SpaceAcross>¬<SpaceAround>¬</SpaceAround>¬<QtyAcross>1</QtyAcross>¬<QtyAround>1</QtyAround>¬<BestStockSize>13.0000</BestStockSize>¬<ToothSize></ToothSize>¬<Distortion>96.4600</Distortion>¬<Machine></Machine>¬<ToolComments<</ToolComments>

This is the formula for the Text Display Object with the Rich Text option turned on in the Options panel:

"<b>"+richtextdata(xtagvalue(Tooling,"DieNumber"))+"<color:00FF00> |</b></color><bgcolor:FFFF00>"+richtextdata(xtagvalue(Tooling,"SizeAcross"))+"</b>"+" x"+"<b>"+richtextdata(xtagvalue(Tooling,"SizeAround"))+"</bgcolor></b>, <b>"+richtextdata(xtagvalue(Tooling,"QtyAcross"))+"</b><i> ac </i>("+richtextdata(xtagvalue(Tooling,"SpaceAcross"))+" sp)"+" x <b>"+richtextdata(xtagvalue(Tooling,"QtyArround"))+"</b><i> ar </i>("+richtextdata(xtagvalue(Tooling,"SpaceAround"))+" sp) :: "+richtextdata(xtagvalue(Tooling,"Shape"))

The output I get is:

Do you have the Rich Text option turned on?

I do have it turned on. Im wondering if there is some hidden characters in the data. I copied the data in one record from the field Tooling, pasted it into TextEdit which was set to plain text and then pasted it back into the Tooling field. Same anomaly. Then I thought it might be the “¬” character so I replaced that with “;” and still had the same result. Is there a way to find out what all the characters are in a field?

I just tried changing the formula, adding more to it a step at a time. It seems when the formula gets to the backgound rich text tag everything gets weird. In this image I have only a partial formula but the TDO is displaying all of the data in the field.

Here is a quick way to see if there are any odd ball characters in the text below chr(32):

message characterfilter(Tooling,{?(asc(import())<32,asc(import())+"•","")})

This will generate a list and the values of any invisible characters other than the space character hidden within your text.

Thank you Gary. It came up empty.

The only remaining test I can think of would be to copy and paste the data I listed above (which I retyped from your screen shot) into your Tooling field. Then copy and paste the formula I typed above into the formula of the Text Display Object and see if you still get the strange output. These both work for me at this end producing the result I showed above.

I did as suggested and I had the same result you did. So I repasted my data in the field and still had the same result you did Gary. So it appears that I have some anomaly in my formula. I will dig into that later today.

Thank you Gary and James for your help.

So here was the problem.


Should of been xtagvalue() instead of xtag()


Those pesky details. Thank you again for your help.