Recent shared DB error messages

I’ve been banging on the Team Server pretty hard lately and I’ve been receiving some strange behavior. Sometimes when I open, or even click on a shared database, a progress window named “Progress” with a progress bar appears. The problem is, it never progresses. It just sits there and I can’t get rid of it. The only solution is to Quit Panorama X. I had two of them on my screen at the same time today just by clicking on two different databases.

Secondly, Sometimes I get an error when I synchronize that states “WiFi for crash statement can’t wait”.

Lastly, when working with shared databases, I often can’t quit Panorama. Can’t close any windows, can’t quit. I have to force quit.

The good thing is, in general, it’s working pretty well. I’ve given up on text lists and matrices with large databases (too slow) but most everything else is working well. I love being able to upload partial fixes like just changes to procedures or forms. Sometimes it doesn’t take the first time on remote clients but it always works eventually.

I have a procedure that I can call from the Action menu with one line, which closes any stray Progress windows.

 closeallasyncprogresswindows "Closed it!"

When Panorama on the client performs a potentially slow operation, it normally displays the progress of that operation in the tool bar. But if the toolbar has been hidden, that’s no possible. In that case, Panorama opens the separate progress window, much as the Finder does when you copy a file. Normally, that window disappears as soon as the operation is complete.

Are you using a window that doesn’t have a tool bar? Oh – this progress window will also appear when using a shared database with no visible windows (in other words if you open a shared database with opensecret).

I’m glad Tom mentioned the closeallsycprogresswindow statement because I forgot all about it! It is documented, however.

I always appreciate it when the exact error message is included. However, now I have to ask you – is this actually the exact error message? There is no text “WiFi for crash” or “crash statement” anywhere in the Panorama source code.

I wonder if that could be this bug? If it is, the good news is that I have recently fixed it. In the mean time, just clicking on another record will clear the problem. Or Command-S.

Yes, but not intentionally. As I stated previously, I save every DB with a tool bar, however, the databases open with or without a tool bar as they see fit. Now at least I know that that is probably why the progress window is coming up. Thanks for the tip on how to close it Tom, but it seems that should be unnecessary. If it’s going to open by itself, it should close by itself. Asking a user to do it is seen as a bug.

It flashed pretty fast and I wrote down what I thought I saw ASAP, but it definitely started with “WiFI” and ended with “can’t wait”.

I clicked on other records, clicked on other open DBs, saved several times, nothing worked. This isn’t the first time this has happened and again, it’s getting reported to me as a bug. It’s just the first time I got around to reporting it. I’ll confirm my attempts the next time it happens to me. If it’s fixed, that means in the next release after b25, correct?

Really? Is anyone else seeing this problem? The tool bar should always come back the same way as the window was last opened. I do recall problems in that area several years ago, but not for at least 3-4 years.

Of course. That’s why I said “Normally, that window disappears as soon as the operation is complete.” If the window doesn’t disappear that is not normal, in other words, a bug.

What do you mean “flashed”? This was not in an alert that you had to dismiss with a button? If it was a notification, you should be able to review it at your leisure in the notfication center.

If you see this error again, please try to get the exact error message. There are about a quarter million lines of source code in Panorama X, it’s impossible to search them manually and I do not have them all memorized.

Yes, in b26.

I must say, the databases take turns opening differently, but every time at least one opens in a way it was not saved. Today a database opened to the data sheet. Weird.

I have never seen anything like that.

Today a database opened to the data sheet.

It won’t help with the toolbars, but it sounds like you would benefit from learning about this feature that was added 2-3 months ago.

Thanks Jim, I’ll give it a try.

I’m still having a problem with the progress bar hanging. Windows continue to open without a toolbar even though they are saved with one and quite often the progress bar hangs which stops the opening of other databases from the .initialize procedure.