Properties disappearing

I have a form converted from Pan 6.
I’ve added a button titled "Pledge Button"
In the procedure pane I’ve put in: message "Worked"
switch to data mode
press button
Go back to graphics mode, select Pledge Button and there is nothing in the procedure pane

repeat several times.

Quit PanX
Reopen the file
Switch to Graphics
select Pledge Button
re-enter message “Worked” in procedure pane
switch to Data Mode
Press button and it works.
Created another button and it works.

Is there anything I could be doing that interferes with the operation of the procedure pane?

On a related not, I had a Text Display Object on the same form with a procedure in the pane that wouldn’t stay deleted until after I quit PanX came back and deleted it.


I had a similar problem last week and tracked it down to a problem with the code on one of the procedure panes that silently locked things up until it was corrected. My exact problem was with a missing parameter that was not shown as a syntax error in the pane when I hit Apply. It then locked me out of having any other changes made to any object’s procedure (even the one causing the problem). I had to close the form and reopen again to make the correction that fixed the problem.

If this is also your problem, you might have it reappear if the object with the bad code is activated. That was my story anyway - may or may not be the same problem for you.

Could have been the same problem. I switched to message “Worked” after a slightly more complicated procedure didn’t work. I made the correction (adding an endif) but it wouldn’t take. So just deleted the whole thing, tried the message, etc. Not sure if I tried just closing the form instead of quitting PanX. Guessing it counts as a bug.
Martin McCaffery