Program crashing on field search

Each time I’ve searched my database in one of the named search fields the program crashes. This also occurs, so far, when I’ve tried to duplicate a record from the drop-down menu. I’ve tried rebooting. Should I download program and re-install it? Help!!

Rebooting Panorama X or your Mac?

I would re-install Panorama X and, if that doesn’t help, turn your Mac off and restart it.

Thanks, Michael.

Have re-installed PanX Shut Down and restarted. Same problem. Trying to duplicate a file in the data base from my drop down menu crashes the program every time. No trouble in past six months, just started this today.

Best Regards,
Len Codella

Is it just the one file? Try duplicating a different one - if that causes Panorama X to crash, you have a problem whose solution lies beyond my abilities. If it doesn’t crash, your original file is corrupted to some extent and you should rebuild a new version of it.

You wrote “one of the named search fields” which implies that other fields work. If that’s the case, you my well have something wrong with or in that field. Is there anything different about the field name? Is it reasonable to scan the contents of that field to see if anything has unusual characters in it? Data copied and pasted from some sources can include characters that you wouldn’t ordinarily type into a field.

There shouldn’t be any circumstance in which doing a find or a duplicate record causes a crash – unless your data is corrupted in some way. I’ve never heard of a corrupted database causing a crash, but there is a first time for anything, and obviously corruption could cause all sorts of problems. I would suggest downloading a sample database from the Panorama X Database exchange and see if the same problem occurs. If that works, then your database has a problem. You could try exporting the data as text, then re-importing it, but if it is corrupted, the export might fail. At that point, you would want to go back to a previous uncorrupted version, perhaps with Time Machine (if you’ve been keeping Time Machine backups of your system).

Like James Cook, I was puzzled as to what “named search field” means. That term isn’t used in Panorama’s documentation anywhere – any field is searchable – so what do you mean by that?

Hi JIm,

My terminology leaves a bunch to be desired as PanX is still a mystery to me.

When I open my data base at the very top of the screen is the control bar with all of the drop down menus allowing selection of a particular process. Listed under the RECORDS heading, the Duplicate Record command crashes the program every time regardless of the actual Record selected. Most of the other selections, like Cut, Copy, Paste, Add all work as they should, with no problems. This anomoly just started up two days ago, never a problem before.

I have removed and re-installed PanX several times already and have both Shut Down or Restarted my Mac, but so far, no luck.

I hope this is a clearer explanation of my problem. The fields are not a problem, just the Record command.

Best Regards,
Len Codella

I don’t have any additional suggestions beyond the ones I made yesterday regarding the possibility of a corrupted database, and suggestions for seeing if that is true.

Thanks, Jim.

You were correct, the DB was corrupted. Since updated and all i well.

Thanks to all for their suggestions and interest.

Best Regards,
Len Codella