Procedure crash

Getting a consistent crash when running a procedure. Crash message includes this and I wondered if these few lines actually give a reason for the crash (other than the fact that my code is creating a corpse…):

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000


PS I have a vague memory that Pan has a way to log/record problems like this but not finding it in the help. True or am I hallucinating again?

This is discouraging. The same PAN X procedures that were crashing repeatedly yesterday at home on a new Mac Mini running the latest OS, run fine on my antique Mac Pro at work running 10.11.6, El Capitan. Now what?

And as an additional test I just tried it on my laptop recently upgraded to Mohave 10.14 and it also crashed. So until somebody tells me otherwise, I’d say something in Pan doesn’t play nicely with something in Mohave or vice versa. Suggestions welcomed!


You have not told us anything what your procedure code is doing. Mojave has some new security features. So if your code is interacting with files on your Mac, it could make sense to give Panorama X Full Access to your hard disk in System Preferences > Security.

The Pan procedures are all within the database–nothing external. But I’ll try your suggestion anyway just in case. I’m at my wit’s end.


Hmmm. It crashed again on the laptop but when I ran it again on the Mac Pro, this time it crashed there also, even though it ran fine earlier. So perhaps there is some nasty error in my code which I am missing. I will go dig some more and then probably post the code and beg for help. Sigh. There is nothing worse than something which works sometimes…

Sorry, no.

Whenever Panorama X launches, it automatically checks to see if the previous session ended with a crash, and if so, it automatically sends the crash report to provue’s server. It also symbolicates the report, so it actually contains more useful information than the crash message you see on your end.

So I can see that in the past two days you have had a bunch of identical crashes on both your MacBook and your Mac mini. Even with symbolication, it’s unfortunately very difficult to glean useful information from crash reports. I can tell you that though this may be triggered by a procedure, the crash is actually occurring in a Text Display object. This object is attempting to display a field and it would appear that the data in the field is corrupted somehow. So it may be that the problem is in your code, or it may be a problem with the actual data. Is this database being shared between computers somehow? Maybe Dropbox or file sharing? Possibly exporting and then re-importing the text might help? Though I’ve never heard of a problem like that with Panorama X, but I suppose there is always a first time (and the problem could have originated with a hardware glitch, then spread across machines via sharing).

I don’t see any record of a crash on your Mac Pro, but if you didn’t launch Panorama again on that machine, the report won’t have been submitted yet.