Problems with Panorama X auto-updating?

I’ve just gotten a report from one user that auto-update doesn’t work reliably for him. I’ve never heard of any other reports of this, so I am wondering if anyone else is having this sort of problem. Panorama X uses an auto-update framework called Sparkle to do automatic updates, which is used by hundreds (maybe even thousands) of Mac applications. I’m not sure what I can do if there are problems, other than ripping out Sparkle and writing my own auto-update code (there are literally only a couple of lines of my own code involved, so any problem would have to be in Sparkle itself). I’d be very reluctant to do that, since the code is quite complicated and Sparkle has been very widely tested as one of the most widely used third-party frameworks on the Mac for nearly ten years. But I’d like to know if this is a widespread problem I need to worry about.

I had the problem when I ran Panorama on a Wireless network which required authentication to use the network, like in some coffee shops. After I finished clicking through the browser windows to get a valid internet connection, and I restarted Panorama, then everything worked well.

Strange. It’s been this way for me since the beginning, and it’s my
second install of PX (the first got fried somehow quite a while ago). I
see nobody else is confirming a problem so far. Probably something on my
system, but it’s happening on two different computers, one running El
Cap and one running Sierra…I don’t think I’m running anything else
very unusual.
If you don’t hear from anyone else it’s probably not worth worrying about.

Jim Rea wrote:

With “VPN Unlimited” connected, PanoramaX > Check for Updates was grayed out and did not work. I turned off VPN and PanoramaX automatically updated and the “Check for Updates” worked.

What is “VPN Unlimited”?

On both of this week’s updates, the auto-update feature worked, but not until the 3rd start of PX, not right away. Check for updates was greyed out, until the update had taken place, then it was available.
I don’t use VPN, except in Opera, and it wasn’t running during my updates. So I still think something subtle is going on…

“VPN Unlimited” ( ) by KeepSolid, Inc. is a Virtual Private Network service.