PanoramaX Login Does Not Stick

After the installation of macOS 12.3 I tried to recover some disk space, and one option in Clean My Mac seems to have been too rigorous. It deleted registration infos of some of my apps; one of them was PanoramaX, where my login info was deleted. I was able to re-enter my login data and successfully to log into my account — but the login now does not get saved, and I have to enter my login data every time I launch Panorama X.

Do you have advice how I can recover the steady login from my TimeMachine backup or which files I have to delete to build a fresh set of preference?

O.K., a user caches cleanup with OnyX and a Mac restart later, all is working normally again, and my login survived quitting Panorama X.

That’s good, because I had no advice for you other than completely deleting Panorama preferences.

It was not really good; the problem reappeared — for Panorama X as well as for other apps like FontExplorer X that had lost my app settings, and when I tried to repair the settings, the changes did not stick either. Very weird.

Thank God I had saved a backup of the status before the macOS update, and I was able to recover my complete user library folder. I had to do some additional work reindexing the mailboxes and rearranging my “Favorite” folders in Mail, but now everything seems to work as expected again.

I think MacPaw is a good company (and for those who don’t know they are based in Kyiv, so I hope they are ok). Nevertheless, I wouldn’t ever use Clean My Mac or any other “cleaner” software. I think it’s just way too risky to use a program that removes files from other software. Your experience today reinforces my opinion.

For future reference, Panorama’s preferences can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

I have had a lot of good experiences with CleanMyMac X as long as I carefully selected what to clean up (e.g. user caches, log files). — This time I additionally followed a CleanMyMac X proposal to regain about 60 GB of “purgable SSD space”. This sounded similar to what I knew from apps like DaisyDisk, but it was a too rigorous step. It deleted 15 GB from my user Library and created those problems I reported above.

Maybe I have blamed the wrong app. Today the same problem (lost registration infos, not sticking preferences) reappeared to my surprise, and MacPaw’s CleanMyMac X was not involved at all. I have a new culprit: Piriform’s CCleaner. I have deinstalled it now.

I never heard of this program. A google search turns up this. :scream:

Bottom line, I don’t want any software going around erasing files on my behalf. Even if it takes much longer, I want to do that myself.

Another follow-up: Tonight, after a long day of work and everything working well, I suddenly got the “Not authorised” warning in Panorama X again. Today, there was NO cleaning maintenance involved.

Maybe I happened to see a Finder bug that Howard Oakley had reported on eclecticlight.co, a bug related to memory leaks with Finder searches.

I restarted my Mac, and everything was working well again.

If you keep having problems you might want to set up and migrate to a new user account on your computer. That would be a huge amount of work, but these weird problems are very concerning. Perhaps your cleaning efforts did more damage than first realized.

Login issues different but also interesting…

My server was not serving as the shared dbs were not allowing edits. Couldn’t figure out why. Eventually I think it was on the Client tab of the server that it displayed in Red something akin to ‘Not serving due inadequate balance in account’. I thought huh? I knew I had plenty of a balance. Then further searching found that the server was no longer logged in to my account. I logged in and all was fine.

As you, Jim, and I read on Twitter, Joe Workman has exactly the same problem regarding macOS 12.3 . But it seems a Mac restart (to be exact: two Mac restarts) are the (temporary) rescue for me. I am still searching the trigger that is causing the issue. It seems, RapidWeaver — maybe its plugin or stack updates — could be involved, because my Mac keeps re-opening RapidWeaver at the first restart …

I thought about posting that here, but I see you saw it anyway. Sounds like macOS 12.3 is the most likely culprit, but it is interesting that you and Joe are both having the problem and are both RapidWeaver users. Hard to imagine how RapidWeaver could be the cause though.

I don’t know what is on Twitter but I do have and use RapidWeaver.

This is the tweet @KJM and I were referring to.

The issue is solved! What was happening?

Isaiah Carew, developer of the Stacks plugin for RapidWeaver, wrote on Twitter:

There must be something new in cfprefsd. writing a bunch of sparkle update prefs files seems to kill it. It just hangs, then all NSUserDefaults reads return nil and all writes fail.

But not just in your app, every app has all nil prefs!

:clown_face::mans_shoe::mans_shoe:

This was the reason for the Login issue with Panorama X.

Joe Workman found an easier way (than a double Mac restart) to get back to normal operation:

How to fix without a Reboot

If your Mac gets into this funky state, you could reboot. However, there is a quicker and less annoying fix. Open up Activity Monitor app and search for the cfprefsd process. Select the process and quit the the process. MacOS will restart the process automatically when you quit it. This should fix your system.

In the meantime Isaiah has published Stacks 4.2.4b1_6021 that solves the problem that had been triggered with every stack updates search in Stacks.