Panorama X doesn't work for me anymore

Mac Mini early 2015, OS 10.11, other programs OK

When I click on the Pan X icon in the dock it opens but only shows a white and clear window.
Click on View>Datasheet: nothing
Click on View>New Form: nothing
Click on File>Open: nothing
Right Click on Pan X icon in dock to open file: 2 white rectangles
Quit Pan X: nothing
Force Quit Pan X: worked
I suspect there is a mysterious file somewhere that got corrupted; prior to this problem Pan X was quiting often.


Try downloading a new one.

I did, no difference

Have you tried launching the actual application from within the Appliciations folder versus the alias on the Dock?

Just tried that, no difference.

OK, I put Pan X from the applications and download folders folders into the Trash and emptied it.

Downloaded Pan X and still get white rectangles, etc. There must be file somewhere that has my registration info because Pan X started right up. Maybe that file is corrupt.


There are some files in your User’s Library folder.

  • Library/Preferences/

  • Library/Application Support/
    Panorama X

  • Library/Saved Application State/

There may be others that I’ve missed.

Unlike Panorama 6, Panorama X is a standard Cocoa application that uses completely standard Apple code wherever possible. Instead of saving preferences and saved state itself, Panorama uses Apple’s code for this. One downside of this is that I don’t know the details of how this code works. However, I have done some research that I hope is helpful.

I think Gary has done a good job of listing files in your User’s Library folder that might be causing your problem. Let me see if I can shed some more light on this.

/Library/Saved Application State/com.provue.PanoramaX.savedStat

I think this file (which is actually a folder) stores information about what state Panorama was in the last time it was open. I think you could delete this safely and a new one would be created the next time Panorama launches. I would try this first.


This file appears to contain the list of items in the Recent menu. I think if you delete this it will erase that list, which would then be rebuilt as you open files again.


This file contains the general preference information for Panorama X, including your account information, toolbar configurations, search options, favorite databases, channel settings, open view options, etc. You can delete this file and a new one will be created the next time Panorama launches, however, you will have to log on to your Panorama X account again and reconfigure any preferences and configuration you have set.

At this time Panorama X does not use any files in the Library/Application Support folder. All of the information that Panorama 6 stored in the Application Support folder is now stored in the /Library/Preferences/com.provue.PanoramaX.plist file, Application Support is not used (however it will be used for some server support files).

@geoffearl I think I would recommend that you first try deleting the

/Library/Saved Application State/com.provue.PanoramaX.savedStat

folder, if that doesn’t work, then try deleting the other two items.

@geoffearl Did you get Panorama X working again? If so, could you share what the solution was?

It’s back!! Here is what I remember doing (old mind):

/Library/Saved Application State/com.provue.PanoramaX.savedStat - no change

/Library/Preferences/com.provue.PanoramaX.LSSharedFileList.plist - couldn’t find

/Library/Preferences/com.provue.PanoramaX.plist - no change

Forced quit and went out to mow.

Opened Pan X and played with clicking on File menu items, nothing happened except accumulating white rectangles, also used cmd-W to try to close some of the windows. A white window showed up that looked like a dialog bow, so I pressed “Enter”. Pan X came back.

I had to reset my password, so maybe the preference file was the problem. I remain clueless but curious.

Everything seems normal to a “light” user.

Thanks for your help

Same symptoms returned; diddled with it a few times - no change. Started Pan X again, seemed OK, changed password, good to go. For a while?