Panorama not working for other users on same computer

I have different user accounts set up for different clients, and I occasionally use Panorama X in each user space. Since my update to macOS Sierra, Panorama X works fine in the main, admin account.

However, I just tried to use it in a “client” account and it barely functioned.

The first time I tried to open a database, I got weird (to me) error messages so I quit and re-launched it. This time, I was invited to provide my e-mail address and password/code. This I did, at which point Panorama informed me that I did not have write access to some file that would allow me to log in. It asked if I wanted to duplicate this file, which I did. I then provided by e-mail address and password thingie, and the database opened.

However, when I tried to do a find in a 17,700-record database, though, I got two error dialogue boxes, one overlapping the other. The top one said:

“ChangeObject statement can only be used in a form window.”

The one beneath this said:

“You don’t own the file “_FindSelectLib.pandb” and don’t have permission to write to it. You can duplicate this document and edit the duplicate. Only the duplicate will include your changes.”

I force-quit Panorama X, which seemed to be the only way to get out of this loop.

I then double-clicked on the “duplicated” file from the credential step above, and Panorama X seemed to open. However, then it gave me another error message, which had all kinds of useless information:


How to I convince Panorama X to allow me to use my databases in other accounts on my computer?

I think for now the answer is going to be that Panorama only works on the main account. Obviously this is something that will have to be worked on.

Ouch. Guess it’s time to convert each of these databases to Filemaker.

Perhaps I wasn’t clear – this is a bug that needs to be fixed, and it has been on my radar.

I think there may be an awkward way to get around this for now. Remove from the main /Applications folder, and install a separate copy of it in each user’s ~/Applications folder (you may need to create this folder in the user folder. As long as each user is running a copy in their own folder, I think it will work.

Jim, I got what you were saying, but even though I don’t need these databases all the time, I still need them.

This worked. Thanks.