Opening Connection to... when using a shared db

When I use File/Open to open my shared database, I sometimes get this notification…

When I first saw this, it gave me a warm and fuzzy feelling telling me that all was good. But I have come to learn that this is not a good thing.

Info(“ServerConnection” will return 0 (or False) in this situation.

What I am supposed to see (if all is good) are some following notifications stating something like “Opening xxx on Automation 21” then another, maybe like…
“Already synchronized : 308”

Without these following 2 notifications, I, or users, have to figure out that the server is down.

Now that I have figured out that the server is going down on its own, what Instrumentation can I run to determine why.

If you open the database and it can’t connect to the server you should see a lock icon in the toolbar. Are you seeing that?

No. There is no lock. And I know today that the absence of that lock means that there is no connection to the server. And that is my point. While I am finding that the server is quietly shutting down, when I open the db, and there is no connection to the server, I do not want a notification that says 'Opening Connection to /ServerName/ as that does nothing for me. In the days of Enterprise, if the connection to the server did not happen, there were bright orange notifications to anyone opening the db. Today, there is no notification. The user has to remember to look up and look for a lock. This is not a good thing.

There seems to be a bug. When you first launch Panorama, the first time you open a shared database the error checking is not working correctly. If there is a server error (I tried it with the server not running) I get the symptoms you describe – no notification, no lock icon, and Panorama allows you to edit the data without complaint as if it was a single user database, though of course changes aren’t saved to the server.

If I open another shared database, the error handling works properly. A server error notification appears, the lock icon appears, and Panorama will not allow you to edit the data.

If I close the first database and re-open it, it works properly the second time. It only fails for the first shared database after launching Panorama. I’ve written this up in BitBucket.

As I mentioned above, the lack of a notification is a bug. Normally a notification does appear.

If you prefer an alert instead of a notification, you can adjust that in the Preferences:Client panel.


With this option, you’ll see an alert instead of a notification.

Remember, you can easily share a standard preference configuration to all of your users to make sure everyone has the same preferences.

I do appreciate Notifications rather than Alerts but that is not the issue.

Just now, I had 2 shared databasese open. I closed one of them. I then went to the server and used the Preferences to shut the server down. It did tell me that I still had 1 db still open and I opted to shut it down regardless. With the server shut down, I then went back to my computer and opened again the db that I had closed moments before. It opened without a lock or any notification.

When I attempted to resolve that issue by using the Connect to Server in the File menu, I got an error ‘WaitForTask statement cannot wait’. But of course this was with the server still shut down. I went back to the server and started it up again. Back to the 2nd db and another attempt to Connect to Server. Again the error ‘WaitForTask statement cannot wait’. Hmmm. I looked again and it had in fact connected to the server and the File menu now showed as Disconnect from Server and I had my WiFi signal icon in the Select Status window.

Thank you for the additional details. None of this behavior is intentional. Hopefully it’s all just one bug. I’ve spent a lot of time working on edge cases of server failure, but obviously not enough time yet.

With today’s b25 version release, I am continuing to get the 'Opening connection to allowing me to think all is well. But alas, the server has shut down on me and I do not know when it did, but the opening of the shared file did not give me any notification. Only the lack of the WiFi signal icon.

The b25 release notes describe all changes made, and this problem isn’t mentioned because it wasn’t addressed. It’s not necessary to re-state every open issue with each new release.