Mysterious word Label in bold

Hello all,
I have a database in Pano 10 where individual records have a view in graphic mode containing text in various rectangles. This used to work perfectly until recently. Lately I discovered that at the end of the text within the rectangles there appears the word Label in bold. This wasn’t written on purpose there, it doesn’t appear in all rectangles and I didn’t make any changes to the architecture a of the database since the time before this word appeared. The word can not be simply deleted. The only changes were several Apple OS updates, so I suspect, this is some kind of an Apple influence.
Can any body shed a light on this mystery?

Any chance you could upload a screen shot?

Sorry, I have never heard of this. Please make sure you are using the latest Panorama X 10.2 b26 version.

When you drag a Text Label object in Graphic Mode into the window, it has the word “Label” in it, but in plain #SystemFont only. To let it appear in bold style, at some time you must have set its font to #SystemBoldFont.

When you say you can’t edit this object, I suspect there might be a transparent, locked rectangle above it, maybe grouped to it.

If there is a object group, select it, ungroup it. Select the rectangle, unlock it, remove it. Then you might be able to delete your unwanted Text label object, too.

Another way to solve the problem could be to edit the form’s blueprint or to recreate this form with the wanted elements only.

Hello KJM,
you have uncovered the secret. In fact, I had something like 8 transparent rectangles above the word Label. I started to patiently delete them one by one until I reached Label and then could delete it as well. Thanks, this solved my first problem. (How these rectangles got there in the first place, I haven’t the faintest idea).

Thanks again


Hello CooperT,
as you can read in my answer to KJM, the original problem is now solved. However, a much greater problem arose out of the blue: my carefully constructed views in graphic mode forming part of this database seem to have vanished. When I call them up now, it says “GoForm” only works with a window that already contains a form. My forms suddenly don’t exist, it seems.
I could find an older backup version where they still exist. Now I have to work out how to transfer them to the latest version of Pano, in stead of making them anew from scratch.
So sorry, can’t send you one of these forms for now.


That error means that the active window, at the time you tried to execute the goform, wasn’t a form. It was probably the data sheet. GoForm will replace one form with another, in the same window.

If starting with no windows or only the data sheet window open use openform, not goform.

This is almost certainly not the case. Please look in the View menu, you’ll see your forms are there just fine.

Panorama 6 could switch from any type of window to any other type of window using the goform statement. Panorama X is not quite as flexible. The goform statement can only switch to a different form it the window is already displaying a form. If the current window is the data sheet, you’ll get the error message you describe. This doesn’t mean your forms are gone, but it does mean that you can’t access them in the current window – you’ll have to open a new window using either the View menu, or the openform statement.

Hello Jim,
as I discovered now, my View Menu from the Toolbar is gone. I have the latest version of Pano (10.2.0.b26) and it used to work fine, opening my windows with their respective names scrolling down in the View Menu. This is now gone, that’s why my problem opening those windows. I had thought they disappeared but in reality it is the View Menu, the tool for opening them which is gone. Why this happened, no idea. Has my Pano version become corrupted? Should I download a new one and try?


Are you really having a database open and then no View menu? (In other words: There is regularly no View menu when there is no database open.)

That’s correct.

Perhaps a screen shot?

This means that you are not logged in to your Panorama account. Since you probably didn’t log out on purpose, what probably happened is that your Panorama preferences have gotten corrupted somehow. Panorama uses Apple’s standard system for managing preferences (used by virtually all macOS apps, including all Apple apps). Sometimes this system fails for unknown reasons.

There is no way to uncorrupt preferences, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

Thanks, Jim, this gave me back my View Menu and now I can again open my graphic windows clicking on their name, as before.
What a mean trick that was from Apple! :angry: