Morph Field does not work with Lookup( function using Help----Relational Workshop Menu/Sub Menu with Apple Silicon

I create the formula in the Relational Workshop and use the formula fill or Morph Field Dialog to grab the data.

Paste the formula in and on my Intel PowerBook it works in Field —Morph — Morph Field and Field — Morph —Fill with Formula.**

On Apple Silicon Mac Studio running Ventura no dice.

Even though using the Menus “Field” — “Morph”— “Morph Field” shows the before after result when I click the Morph Button on the Datasheet NOTHING HAPPENS.**

Spent hours until finally I tried it on my Notebook with Intel.

Works like a charm.

I cannot duplicate your results. The M1 version of Panorama has been out for a year and no one else has reported this. I’m pretty sure someone would have noticed if this didn’t worked. Please double check your results.

Rather than using a dialog, I would create a short procedure to do this.

field "whatever the field is"
formulafill lookup("   My Recipe....",...)

That way you can do it over and over again without having to re-enter the formula.

However, you should not use formulafill for this at all. Instead, set up a relation between the two databases and use a join. It will be easier and MUCH faster.

OK Jim,


I will try to document it for you.

Thanks for the tips.

I’ll try with another two databases too.

But it works on my Laptop.

I agree, someone should have seen this before if it is a systemic bug.


I wonder about all those white spaces in " My Recipe…


It was so in a folder it goes to the top.

Good idea.

I will eliminate them and see if that solves my mystery.

Bruce, you must be Clairvoyant!

Eliminating those leading spaces eliminated the problem, although Jim gave me suggestions using the procedure instead, which curiously worked even with the leading what was intend to be spaces.

I even then introduced starting with one space and going to 3 spaces and the problem did not reoccur.

I’m gong to do some forensics on those file names. Perhaps some invisible character (I still like my term ghost character) snuck in there and fouled thing up.

Time for Time Machine.

Thanks for your wondering.

I will post what I find. Man, hours into that!

Jim, thank you too as usual.

Now to learn how to “Join” database. I have my marching orders.

Do you have a cat?

1 Like

No. Why do you ask?

I wondered about those as well, but they were so obvious that I figured they had to be there on purpose!

Cats are a known source of mysterious typing!,

How could I have known that spaces leading a filename could be disastrous. Why the difference vs 5 leading Capital As?

Agreed, perhaps not true spaces but something else invisible is a danger.

I can confirm that 5 leading spaces initiates the problem.

Again, I had leading space so that sorting in List View in a folder put those file at the Top.

Lesson learned after hours of efforts. The good new is that I learned to make screen movies in Quicktime since my other software on that has been obsoleted.

And I am again to link files post Pan 6.

Thanks again for the help.

Panorama doesn’t care if a filename has leading spaces. However, I think it’s a bad practice, because it makes it so easy for you to make a mistake. Especially with multiple leading spaces. Are there 5 spaces, or 4 or 6? You better get it right - every time. And as you say, there are other characters that are invisible, how will you tell the difference?