How do I open a Pan 6 database in PanX?

How do I open a Pan 6 database in PanX? I gleaned that I need to import the database, but when I try import, I get a blank box with no databases to choose from. How is this done?

First of all: Read the documentation available in the Panorama X Help menu, specially the first chapters. The 4th chapter is “Importing a Panorama 6 database”.
Panorama X can open every Panorama 6 database, once you have named it with the “.pan” suffix.

This topic in the Panorama Help should be helpful.

And this free 42 minute video should be even more helpful.

I’ve tried to open a couple of files, one complicated one basically a data sheet. Changed the suffix to .pan. Intel processor. No binary files, no server, etc.I just get nothing when trying to open.
Using File/Open the files are selectable, but when I click them, the window closes and I’m just sent back to the Untitled open screen.
If I try to drop the files on the dock, same nothing happens.
No error messages
Did I miss a step at installation?

Have these files been saved in Panorama 6? Unless they are actually Pan 6 files even with the .pan extension they will not work.

Sounds like you may have discovered a problem I had when I first migrated a database to Pan X - it opens OK, but it opens without any windows so there is nothing to see (and no error message). Go to View > View Organizer, and you will see a pulldown menu of all databases that are currently loaded, you may just see the one you tried to open there. Select a form from the form tab to make it visible.

Yes. All saved in Pan 6. Even created one to test and nothing. Also tried doing Save As x.pan and no result.

Looked at View Organizer. The only one that shows up is the one I tried importing. It did import the first field of that file (because, I assume, I didn’t have any other fields set up at the time). The drop down will show all of the procedures, but no forms. If I click on a procedure it opens the procedure window. When I close the window I get db info error that the file is not open.

@staylor246 The problem that you encountered was fixed a quite some time ago.

@martinmc Perhaps you have discovered a new problem? Could you put these files in a .zip and email them to me?

I’ve discovered at least one problem with your FILM DBXx database. In this database, the .oldindex procedure contains an error – a CASE statement with no ENDCASE statement. It turns out that Panorama X is choking on that error instead of producing the correct error message, so I’ve created a BitBucket issue and I’m going to work on fixing this.

In the meantime, I suspect that the .oldindex procedure is something old that you don’t use any more (it won’t work in Panorama 6 since it has an error). Assuming that is the case, if you open the database in Panorama 6 and delete the .oldindex procedure then you can open the database in the current version Panorama X.

The other two files you sent me open fine in my copy of Panorama X.

Pan 6 also had some loose ends with if and case statements, for instance, this compiles and runs OK:

case a=b

Yep, Panorama X is in many cases going to be more strict about errors. However, the problem with the case statement was not that there was an error, but that Panorama X was not responding to the error correctly (in fact, it caused the rest of the database initialization to fail).

Ok. When I tried to open the other two, they wouldn’t open. I quit PanX and reopened it and then I could get the other two files open. Apparently, when the FilmDBXx file choked PanX, it wouldn’t let go and blocked the other simple files from opening…

I see a lot of cleaning in my future;>