Crashed and will no longer open files

I was working in Pan X and building a Matrix when all of a sudden the application closed itself. I tried to reopen it and PanX “opened” as it program menu showed the normal options at the top but it would not open any of my databases whether I went to the Open Recent option or if I clicked on the database in the Finder. I tried over multiple days and times to close the app and reopen it again and I was unable to get it to respond to opening a database. I uninstalled (by dragging PanoramaX from the Applications folder to the trash and emptying the trash) and reinstalled it via the latest version link and I am still having the same problem. Can anyone help?


I have been finding similar problems with matrix objects. Are you by chance doing this in a view-as-list form?

I was not in a view as list form. What I’m most concerned about is how to get panX back up and functional. I’m unable to access anything.

Brandy Archie
Please excuse the typos

If you have already tried to reinstall the app without success, there must be some additional files getting in the way. Since Panorama X leaves traces in some ~/Library subfolders, I think, it might be a good 1st idea to start Panorama X with the Shift key pressed. This is a common macOS shortcut to start an app without its saved window state.

That is good to know. I have been restarting the computer.

If you are still having problems, I would suggest deleting Panorama’s preference file


Here’s one way to delete this file.

  • Open a new window in the Finder
  • Choose Go to Folder from the Go menu.
  • Type in ~/Library/Preferences/then press the Go button
  • Find the * com.provue.PanoramaX.plist* file, and move it to the trash

When you relaunch Panorama X, you will have to open the Site License window and log in to your account again.

I tried everyone’s solutions but I ended up with it opening to a blank Site License Dialog box
Screen Shot 2017-09-25 at 9.39.38 PM.png

I’m pretty much out of ideas here. No one has ever reported anything remotely like this. What type of computer and operating system is this?

You could try creating a new user account on your computer and see if that helps.

By the way, it appears that you tried to include a screen shot in your post, but it didn’t work. You should be able to simply drag the PNG file onto your reply to include it.

I uninstalled and reinstalled again and now Panorama will open all of my databases except the one I was working on (and had been working on for 6 hours last thursday) when it crashed. I was able to open an older version of that database that was saved elsewhere before that workday and all the changes I made. But I still can’t open the most updated version. Is there anyway to recover the file before I start all over on 6 hours of work? When I double click on the database file it acts like it is opening but nothing shows on the screen. It even registers as opening as the timestamp keeps updating when I try to open even though the last time it actually opened was last Thursday.

I wonder if it is opening with no windows. Have you tried using Open View… or View Organizer…? You may need to open another database first to be able to view those menu items.

On the other hand, if it really munges things, you should be cautious.

Ok. Just tried that first with another database and it seemed to work fine. Then tried it with the database in question and nothing showed up in the Open View Dialogue Box


Can’t really promise that, since I have no idea how the database is corrupted.

My suggestion would be to try the File>Find & Open dialog. Locate the file in that dialog, then right click on it – do not double click. When you right click, you’ll see a pop-up menu, choose Open Data Sheet Only. If the database can be opened at all, that will do it. If that doesn’t work, then there is nothing that can be done.

I would also suggest that you make a copy of the file before doing this. If you do get it open, it may behave erratically, and you may want the option to be able to start over.

Also, if you do get it open, you may want to use the File>Revert To>Browse All Versions command to revert back to a version that was saved a few minutes before you had the problem. I think you have to use this command on the original, not on a copy (if you open the copy I think there may not be any previous versions).

I think Bruce was assuming that you had read the documentation for these dialogs. Nothing showing up in the Open View dialog is exactly normal, nothing will show up until you start a search. You might want to check out the documentation for Open View and View Organizer, they are very useful and Bruce is correct that they are a different method to possibly reveal a file that is open but doesn’t have any windows. However, for right now, I think Find & Open will be easier for you, just make sure you right click.

I just wanted to say that the database that I had that exhibited this problem now works okay with the latest version of Panorama X with the latest version of the operating system, High Sierra. No crashes!

I do not know whether this will help with Brandy’s problem, but we can hope!

Are you telling us that your database that has matrix objects in a View-As-List form now works?

Yes! My bocce league is safe!

Very interesting. I didn’t make any changes in the latest release of Panorama X that should have affected that, so that makes me think that Apple must have fixed a bug in NSTableView, the underlying code that Panorama uses for the data sheet, view-as-list, text lists, and most matrix objects. If so, that is very cool news.

Very likely! In fact, the crash reports from using Panorama X may have helped them catch the bug.

I have decided that what fixes the bugs in the old versions of the operating system is the new operating system, so I am not one of those people who waits to install the new version “until the bugs are worked out,” or one who whines about Apple not patching old versions. I also allow the crash reports to be sent to Apple, so that they can work on them if it is something wrong at their end. Besides, High Sierra is much zippier than Sierra.

That’s good to hear. I took my laptop in to be serviced because I also felt like it was running slow in general. So they will give it back to me with all current updates as well so I’m crossing my fingers that miraculously that may also solve my PanX problems. :crossed_fingers:t4:

Brandy Archie
Please excuse the typos