Can't Search A Field Named Title

I think I’ve answered my own question, but want to confirm.

I have a text field named «Title» when I try to do a Find/Select from the menu, or a procedure search I get a No Records Selected.

After poking around a bit I saw in the Field properties the Title option, which was blank. Leaving it blank, but changing the name of the Field to «X» I can now do a successful Find/Select.

So I am guessing that «Title» is now an illegal field name.

Is there a workaround that doesn’t involve changing almost every form and procedure I have?

Is there a list of other forbidden names?

This does not seem to be true. I have named a field Title and done successful selections as shown below without a problem. If, however, I have a variable already named Title I get your results.

I’ve just tried again using, Contains, Not Contains, Equal To and still get nothing UNLESS I change the name of the field. I just tried it in a different file (one I have not been updating procedures in yet) and get the same results.

Some sort of search is taking place, you can see the DataSheet flash and I get the No Records Selected, Revert To Previous Selection notice.

Using El Capitan and Pan 10.0.01(2685) if that makes a difference.

You should look for a variable named Title.

Ok, no explicitly named “Title” variables. Lots with Title in the variable name (i.e.:lvTitle). Some unchevroned references to title. Corrected that but no change.
Then the finder froze up and I had to reboot.
Opened the first DB.
Problem solved.
Open the second DB (which I hadn’t checked for variables).
Problem returns-- for both DBs.
Quit/Restart PanX
Check a few of the procedures for variables in DB 2. Find the more unchevroned references to Title, so add chevrons and test. Still bad.
Decided to quit/start PanX again about halfway through the procedures.
So far, working properly.

So, guessing that the unchevroned Title get confused with variables, but don’t cause trouble unless the procedure is called, and then becomes a universal interference of some sort?
FWIW, some of these procedures have been running since the 1990’s.

You definitely have a variable named Title set up somewhere. It might be a permanent variable in your second DB. In that case it might not exist anywhere in the code any more. In the second database, create a new procedure with this code:

unpermanent Title
undefine Title

However, if the problem occurs in all databases, you must have a global variable named Title. In that case, there must be code tucked away somewhere that creates it. Try using the Open View dialog, which will search not only procedures but also form objects.

Chevrons don’t mean it’s a field. They are simply delimiters to show where the field (or variable) name begins and ends.They tell Panorama that everything that lies between them is part of that name, and shouldn’t be interpreted as anything else. A name with chevrons is just as susceptible to being confused with a variable as one without them.

1 Like