Cannot use removeallsummaries when shared database is offline

In a shared database, I started a New Generation of a database. While it was offline, I ran a procedure that grouped records, which created summary records. When I tried to use the statement removeallsummaries (from the menubar), I got an error message that “RemoveSummaries statement failed because database is read only.”
I was not expecting that and thought I could do whatever liked while offline and then upload my revised database. The same error occurs if I try to execute a removeallsummaries statement in a procedure. I also cannot just delete the summaries.

Now when I try to upload the new generation, I get the exact same error message (as I recall uploading a new generation first removes summary records).

Now I am stuck with these records and cannot upload the database or remove the summary records.

From the NewGeneration Window, I chose Revert to Server. The changes I have made for the most part are lost, but it looks like the field I added while offline is present [NOTE: the field was not there.]

Hopefully, TimeMachine will come to the rescue.

Your expectation is correct.

Unfortunately, I cannot duplicate your results. I just tried the same sequence of steps, and I was able to remove the summaries without any problem. Which is what both you and I expect.

At this point the version I am using has diverged quite a bit from the version you have. I suppose it is possible that this is due to something I have changed. However, I do not have any recollection or notes of a change in this area.

Starting a New Generation does not take a database offline. Instead, it puts it into a special new generation mode. So if there is a bug, it sounds like it happened in the New Generation code.

It sounds like it is too late, but if I encountered this situation I would try actually unsharing the database. Then hopefully you could do whatever you want, then re-share it. That would mean that the other users would have to re-download it, it wouldn’t download automatically, but you wouldn’t lose any work. Hopefully.

I did repeat the failure several times. I did save all the changes I had made. Tomorrow I will try to replicate this with a test database and see what happens.