A bug in the `calcenclosingrectangle` statement

When I try to use the calcenclosingrectangle statement, I get an error message about the variable [eRect] which is presumably a variable within the calcenclosingrectangle code.

I tried it and it worked correctly.

If the formula that I use isn’t true for any object on the form, the error I get is “Contents of variable [eRect] have not been defined.” There needs to be a more appropriate error message in this case.

I get the same error if I use “all” as the first parameter.

Seems like this line of the CALCENCLOSINGRECTANGLE procedure is not producing true() even when the first parameter is “all”:

If objectSelectFormula match "all" or objectSelectFormula match {"all"}

It appears that objectSelectFormula=array(«_RawParameters»,1,¬) is returning a leading space in addition to the raw parameters. It matches if I change {"all"} to { "all"} in the line that Gary quoted above.

It all works fine if I change the line:




In that case, you would need to quote the formula, but that’s not how the command is documented to work.

Ok, how about:


Yup, I’d say there are 2 bugs here. Duly noted.