Using semicolons instead of commas in European format CSV files


#21

I live in France and have been using Panorama since forever.

Every month I import a file from my bank’s site (a major French bank, actually the ex-state bank) with the activity on my account for the last month. I usually ask for a TSV file but this time I requested a “CSV” file. And I confirm that, indeed, the separator is a semicolon, which is logical as the decimal point is a comma, and there are lots of them.

Hope this helps.

Ellen


#22

As a French Canadian user, I avoid this issue because my text files are always saved with the tab-delimited option. From the following screen shots, you will understand why.

  • CSV1 gives an idea of the original data.
  • CSV2 shows the “save as” options that I used (1, 2, 3, 4).
  • CSV3 compares the results of importing these files in Panorama X.

Hope this helps.

Thanks,
Nelson