Superalert text size not working


#1

When setting the text size for a superalert message, setting the size for the text to display in the superalert dialog does not work.

E.g.,
superalert STUFF, “{title=”+lTitle+{ scroll=“yes” size=64 style=“bold” bgcolor=“aqua” color=“red” height=3in width=7in buttons=“OK”}

does not display the text in 64 points…


#2

It does work if you leave the style plain.

But if the style is changed to bold, as you have done, it doesn’t work. I have filed a bug report on this.

https://bitbucket.org/jimrea/panoramax/issues/522/in-superalert-dialog-font-and-size-options

For now, here is a workaround that does work:

superalert "<size:64><b>hello",{width=500 height=200 size=64 style=rich}

Instead of setting the style to bold, set it to rich, then insert the tags for the style you want. By the way, using the rich option you can have multiple styles in the alert (or any Text Display object). This is covered in Text Objects video session, nearly half of that session is devoted to rich styled text.