Strange check box behavior

I have a form with a couple of checkboxes on it that behave normally. I’ve just tried to add a new checkbox associated with a field. As far as I can tell all its settings are identical to the checkboxes that work, whether I create the box manually or by duplicating a working box and changing the settings. But on the checkboxes I’m trying to create today, when I click them the check mark appears and immediately disappears; and the checkbox doesn’t toggle. The value of the checked box (Yes) is entered in the data sheet when I click the box, but I can’t get rid of it without manually erasing it. It should disappear when the checkbox on the form is toggled, but it doesn’t. I did check to make sure that the data button object isn’t overlapping some other object; it’s not, and wherever I put it on the form the behavior is the same.
I’ve never seen anything like this before; is there something obvious I’m forgetting?

Later: I made a new simple DB with 3 fields and a form with 3 checkboxes. It behaved totally as expected.

And: I made a new form in the offending DB, put 3 checkboxes on it referring to the same fields. On this new form the checkboxes behaved just as expected. So, what could be interfering with the new checkboxes on the old form?

And: after making and deleting the new form, I went back to the offending form and lo and behold, it is now behaving just as expected. So the immediate problem is solved, but I would still like to know whatever was going on an hour ago…
OSX 10.13.6, PanX 10.1.2

I can’t think of an obvious reason for this behavior. I had an idea that it might be related to the “radio” button option, but when I tried it out it I could not duplicate your results.

Is there any code attached to these radio buttons? Or attached to the field? I assume you would have checked that, but if not, that is something to look at.