Sorry - out of memory


#1

In Panorama 6, I have a d/b with 2.4 million records, eight fields. One is a code field which is used to look up the values for three fields in each record from a set of 670 sets of values in a second d/b. I sort and unpropagate the code field so that I’m looking up 670 sets of values from 670 values in the second d/b.

That all goes well until I get to the stage of selecting all records and propagating the three looked-up fields plus the code field. Two-thirds of the way through this process I get the above error message. I’ve upped scratch memory and expressionstacksize to no avail.

I have a recollection of resetting some memory value (to 2,000?) in a preferences-like box in the distant past but I can’t find anything like that now.

Panorama Reference suggests increasing the preferred memory size in the GetInfo box but I can’t find that option in the GetInfo box for either the app or a file.

Ideas?


#2

You can edit the default memory value in Panorama’s Initialization file:
Open Panorama’s preferences (cmd-,) and use the menu item in the Special menu.


#3

That’s it - thanks Kurt. I’ll see if that makes a difference

m