Saving the page orientation


#1

Is there a fix yet to save the page orientation for a form I created. Every time I print the form I have to go to Page Setup and change the orientation to landscape. Why do I have to do this every time?


#2

I’ll have to look into that.


#3

Thanks Jim. Quick question: In my procedure is there a pan-talk statement to say "go to page setup and change this form to landscape instead of portrait?


#4

Sorry, no, there is not any way to do that, at least for now.


#5

I confirm: If you do a Page Setup for a form, the orientation is not saved with the document.

A workaround: Use the printtopdf statement. Read in the Panorama X Help file about all the programmable options.
Then you’ll get your landscape form printed (in Preview.app) without manual adjustments.


#6

Thanks KJM,
Worked great!!


#7

Hi again One surprising sidenote:
Below is the line I put in my procedure:
printtopdf “-/Desktop/Exhibitor Listing 2017.pdf”,“orientation”,"landscape"
I assumed it would save a PDF file to my desktop and I would have to open it in Acrobat and print.
Much to my surprise, the report printed just fine from Panorama X but I could never find any trace of the PDF files on my desktop. Strange


#8

I wasn’t sure at first sight, but the first sign in your path does not seem to be a tilde ~ (opt-n).
But instead of that you can use this as path and file name:

info("desktopfolder")+"Exhibitor Listing 2017.pdf"

#9

Thanks, I will try it but the question still remains: is the PDF a temporary file on the desktop until it prints and then it goes away?


#10

No. If you provide a valid path, then you’ll get a file on your desktop.


#11

Ok, @CMTA, you’ve discovered a fascinating “bug”. It turns out, if you provide an invalid path, it just goes ahead and prints straight to the printer! This a very happy accident where a “bug” turns out to be a feature.

Of course I really should fix it so that there is an error if the path is not valid, but now I know how to do custom prints on demand without a dialog, so I’ll provide a way to do that. Thank you sir for your serendipitous discovery! :slight_smile:


#12

You are welcome Jim.

I had my happy accident with a little help from Kurt.

Blessings,

– Jerry Jambazian, (Treasurer, Administrator and Webmaster)

Christian Ministries Training Association
Sponsors of the annual IMPACT Convention
Serving the local church since 1952
PO Box 1500
Temple City, CA 91780-7500
(626) 286-6492
Cell Phone (626) 643-9460

e-mail: cmta@earthlink.net
www: http://www.cmtaconvention.org


#13

On a U.S. keyboard, the tilde is shift-backtick. Option-n will put a small tilde accent over the character that follows.


#14

But, it would seem, only for those characters for which it creates a legitimate character, like the Spanish ñ.


#15

Yes, and if option-n is followed by a space, you get a stand-alone tilde.


#16

No - you’ll get a space with a little tilde above it.


#17

I do not know if there are differences between international keyboard layouts, but I have (successfully) used opt-n followed by space to create the tilde symbol that represents the user’s folder in paths.


#18

If I choose Show Emoji & Symbols and type Shift-backtick into the search box, I get this.

If I copy the tilde from Kurt’s post and paste it into the search box, I get the same thing, so Kurt is successfully typing the same character with option-n space. If I type option-n space into the search box, I get this.

Both the name, and the Unicode value indicate that this is a different character. The difference is likely due to differences in the German and English keyboard layouts.


#19

Here is an image of the international Apple keyboard: