Flash art background


#1

Hi,

When I paste a “png” file into the Flash Art Scrapbook, it looks like it replaces the “transparent” background with black.

For example, this icon:

icons8-customer-40

when pasted into Flash Art Scrapbook becomes:

40 AM

Is there anyway to make the background transparent?
Barring that, is there anyway to choose/set the background color?
(Hint: white would be nice! :slight_smile: )

I realize this is probably dealing with the old PICT file format, which, most likely, did not support an alpha channel like PNG does.

And, I guess I could edit the PNG to replace the transparent layer/color with another color …

But, maybe you have an even better idea?!? :slight_smile:

Thanks, in advance.

– Mark


#2

As you suspected, at the time you do the Paste, the system converts the PNG format into PICT format, and it substitutes the background color at that time. As far as I know there is no way to specify what background color will be used. The only option would be to paste it into a photo editor program like Pixelmator or Photoshop and manually edit the background. Hmm, you also might be able to take a screen shot and use that.

For future readers, Panorama X does support alpha channels in PNG graphics.


#4

I have made transparent background images many times in the past for use in Panorama 6. The method I used was with Photoshop C3 to remove the unwanted background. Note that newer versions of Photoshop will not work in this instance and leaves a white background in the transparent areas instead. In PS C3 I open a new image with background transparency set and then paste the image into the empty frame. I use the magic wand to select the background I want removed and delete it. I then Select Inverse and copy. Now I can either directly paste the image into a Pan 6 form or to the Flash Art Scrapbook. Either image will display with a transparent background.

There may be other methods to accomplish this but I have not pursued the problem beyond this solution. And, yes, I just tried it again with PS C3 and it still worked.


#5

Gary: thanks! :smile: :+1:

FYI: I just used Preview to load a PNG, and then “Export …” to PNG with the “Alpha” checkbox unchecked. Worked perfectly. :slight_smile: