Copy and paste records


#1

Sometimes, not infrequently, when I ‘Records>>Copy Record’ and subsequently ‘Records>>Paste Record’ in the pasted record fields are offset. I do not see a pattern but it is a common occurrence as I do this frequently to reuse a record. Does not seem to happen if I use ‘Records>>Duplicate Record’


#2

I am using Records > Copy Record when I want to paste it to a second database (with the same structure).

When you want to use it in the same database, maybe Duplicate Record is the better choice.


#3

except I want to add it at the end of a long list and, thereafter modify fields. Duplicate simply adds new record below. Okay I understand I could then change and resort…but the fundamental question is why to the fields get shifted?


#4

Copy/Paste Record and Duplicate Record actually use the same code, so it is puzzling that this problem would occur. I cannot get this problem to occur, and there have been no other reports. If you can come up with anything that would help duplicate this problem please post it.


#5

I can make something like this occur, if there is a tab within the text of a cell, but it happens then with both Paste Record and Duplicate Record.


#6

That makes sense; I have been resetting tab functions…which would answer the apparent random occurrences. Yes, this is the answer. Thanks!


#7

confirmation:


#8

So are you saying that there is a tab in the Hoke Valve data cell? How did it get there – Panorama won’t let you type a tab into a cell.


#9

In my test, I typed some text that included a tab in TextEdit, copied, and pasted it into the cell. A procedure could also assign some text that had a tab, and it’s probably possible to import it from a CSV file.


#10

Yes, I knew that it was possible, I just wondered how it had happened in Lee’s case, where I presume he didn’t mean to do so intentionally.


#11

Jim, in my case I set the Tab=4 (as shown) and got this result in any field where it was set

.

You are correct; it was not intentional.


#12

That’s interesting how that screen shot is truncated, I don’t know how to do that if I wanted to.

We’ve still got a mystery though, because the Tab=4 option still doesn’t let you enter a tab into the data – when that option is used pressing the tab key inserts 4 spaces into the text, not a tab.

Anyway, it doesn’t really matter at this point. I have entered this in the bug report system.


#13

CMD-Shift-4? , as in:


#14

The screen shot was truncated by the forum. If you click on it, you will see the entire shot that Lee took.


#15

Exactly. CMD-Shift-4, then select the screen area desired.


#16

I think Jim was saying he didn’t know how to get the forum to truncate the shot he was posting. Jim has posted a lot of shots that didn’t cover the entire screen.

The forum will shrink a shot that is wider than the allotted area. It will crop one that is taller. Click on it to see the complete shot.


#17

I did do that and see the entire shot. What I didn’t realize was that the forum would automatically crop if the shot was too tall or too wide. I guess it’s not an option, it just does the crop without asking. I haven’t noticed that in any of the shots I’ve posted, but I tend to use images with an aspect ratio that is not so extreme, I guess.