A couple possible bugs


#1

So I am finally getting some time to play with Panorama X, and I have a few observations.

  1. If open Panorama and i am not logged in, there is no View menu visible

  2. Trying to use the web browser object- the documentation mentions an “APPLY” button, i am not seeing this (see picture) Also, the web browser object won’t display anything no matter what i enter into the box, neither “Literal Text” nor “Formula” have any effect- no website appears in data mode or in graphics mode.


#2

The Options pane of the Properties Panel is used mainly to set wether the information in the Formula pane is interpreted literally or as a formula. The Base URL box is used only for pages generated by web page code entered directly into the Formula pane to show the base path for things like images within the generated page. This is not the area you enter your url info. If you want to go to www.proview.com as listed in your example and residing in your page_url field, then you would first set the Mode to Formula in the Options pane and then in the Formula pane you would enter «page_url» to get the value from that field. You will find the Apply button on the Formula pane and clicking it should reload the formula into the Web Browser Object.


#3

This is a known bug and is described on Bitbucket as issues #209 & #670.


#4

I think the key words here are “not logged in.” The issues you referred to were about the new file that used to open automatically when you launched. The view menu would initially be missing, but would appear when you clicked on the menu bar.

This is about opening a file when you aren’t logged in, and it’s not known what your role is. If I log off with a view menu showing, the view menu disappears, and the only way to get it back is to log back on. I don’t think this is a bug.


#5

i’m not on bitbucket yet…

i’m also not sure the first one is a bug.

cw


#6

You don’t have to be on it to read the posts, just to post yourself. Issue #209 is at

and issue #670, which is marked as a duplicate, is at


#7

As Dave suspected, this is intentional, and has nothing to do with the Bitbucket issues Gary mentioned. If you are not logged on or running a free trial, Panorama is running in a “limited” mode and the View menu isn’t available.


#8

That’s exactly what i am doing. I just tried it again- no ‘apply’ button, no content in browser object.

chris


#9

Here’s the blueprint for the object :

changeobject 1, // “WebBrowserObject”,
“rectangle”,rectanglesize(8, 15, 781, 828),
“color”,htmlrgb(“000000”),
“name”,"",
"$ShadowBlur",“10”,
"$DropShadow",“0”,
"$BorderLeftMargin",“0 px”,
“Formula”,"

Untitled
Panorama X Web Browser
", "TextSize","13 px", "$BorderRightMargin","0 px", "Opacity","100 %", "$ShadowDepth","6", "Locked","0", "$Fill","Hollow", "Procedure","", "ExpandShrink","0", "Tags","", "$WebBrowserContextMenuFormula","", "$ToolTip","", "$ShadowBrightness","0%", "Alignment","Left", "$WebBrowserBaseURL","«page_url»", "Font","#SystemFont", "$ShadowAngle","45°", "$WebBrowserFormulaMode","Formula", "$ShadowOpacity","75%", "Expandable","0", "$BorderBottomMargin","0 px", "$Stroke","None", "LineWidth","1 px", "$BorderTopMargin","0 px"

#10

That’s not what he said. Leave the Base URL blank. Then click on the formula pane, and enter your field name there. The tab for the formula is two places to the left of the options pane you are showing in your picture.


#11

Success. That’s kind of a confusing way to set it up. Thank you!